Microsoft 365 MFA Access Issues

Incident Report for MIT

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 16:30 EST

Monitoring

Microsoft 365 MFA services are operating, and authentication attempts should now be successful.
Posted Feb 23, 2026 - 12:43 EST

Investigating

Some users may experience problems accessing Microsoft 365 services that require multi-factor authentication. We are investigating and will provide updates as more information becomes available. https://x.com/MSFT365Status
Posted Feb 23, 2026 - 11:18 EST
This incident affected: General.