Concur Login Issues

Incident Report for MIT

Resolved

The IRT have verified that service performance is stable.
Posted Jul 08, 2025 - 08:09 EDT

Investigating

Intermittent issues are occurring with logins through the SAP Concur website and SAP Concur mobile app. Affected users may receive an error when attempting to log in.

The Concur Incident Response Team (IRT) is currently investigating and will provide an update. Current operating status can be found on open.concur.com.
Posted Jul 07, 2025 - 12:38 EDT
This incident affected: Administrative Services.