Slow wireless connectivity across campus

Incident Report for MIT

Resolved

IS&T has identified the issue impacting wireless performance and has resolved it.
Posted Feb 02, 2026 - 17:59 EST

Investigating

We are receiving widespread complaints across campus regarding slow wireless connections. IS&T is investigating and we will provide updates as available.
Posted Feb 02, 2026 - 11:42 EST
This incident affected: Network.