Duo Authentication Issues

Incident Report for MIT

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 16:30 EST

Monitoring

The gateway issue with Duo authentication has been resolved and we are monitoring. The phone authentication issue is still being investigated by Duo. https://status.duo.com/
Posted Feb 23, 2026 - 13:06 EST

Investigating

Authentication issues with Duo are currently affecting access to Microsoft services such as Outlook. Users may be unable to sign in. Status updates: https://status.duo.com/
Posted Feb 23, 2026 - 11:16 EST
This incident affected: General.