Investigating Issue with MIT Secure Wireless Network

Incident Report for MIT

Investigating

MIT has received reports of some users being unable to connect to the MIT SECURE wireless network. IS&T is currently investigating the issue. We will provide updates as more information becomes available.
Posted May 20, 2026 - 13:18 EDT
This incident affects: Network.