Duo SMS/Phone call authentication delivery failures
Incident Report for MIT
Resolved
Duo has declared this incident resolved. More information from Duo is available here: https://status.duo.com/incidents/h7lht3g1zv9w
Posted Feb 14, 2025 - 06:55 EST
Identified
Duo is currently experiencing SMS/Phone Call delivery failures. Push authentication is not impacted and can be used as an alternative authentication method.

Duo has identified the issue and are working to deploy a fix. More information from Duo is available here: https://status.duo.com/incidents/h7lht3g1zv9w
Posted Feb 13, 2025 - 14:15 EST
This incident affected: General.