Investigating Issue with MIT Wireless Network

Incident Report for MIT

Monitoring

Services have returned to normal operation. We are continuing to monitor the environment to ensure stability.
Posted Jul 09, 2026 - 20:18 EDT

Investigating

IS&T has received reports of some users being unable to connect to the MIT wireless network. IS&T is currently investigating the issue. We will provide updates as more information becomes available.
Posted Jul 09, 2026 - 18:04 EDT
This incident affects: Network.