MIT call centers unavailable

Incident Report for MIT

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 17:39 EST

Monitoring

Service has been restored to all impacted call centers. IS&T will continue to monitor the situation.
Posted Feb 27, 2025 - 10:51 EST

Investigating

All MIT call centers routing through Zoom are currently unavailable. IS&T is working with Zoom to restore service as soon as possible.

Calls made to the following departments may fail:

MIT Health
Admissions
Atlas Service Center
Benefits
Payroll
Student Financial Services
Teachremote Support
Posted Feb 27, 2025 - 10:26 EST
This incident affected: Telephones.