Microsoft 365 Services Degradation

Incident Report for MIT

Resolved

Microsoft has reported this issue as resolved.
Posted Oct 30, 2025 - 07:13 EDT

Monitoring

Microsoft is reporting a degradation in some M365 services, including Exchange Online, Microsoft 365 suite, and Microsoft Intune. Microsoft will published updates to X at https://x.com/MSFT365Status.
Posted Oct 29, 2025 - 13:41 EDT