Dropbox Access Issues
Incident Report for MIT
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 09:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2024 - 12:30 EDT
Investigating
MIT's Dropbox environment is unavailable from some Dropbox clients. IS&T has reported this issue to Dropbox support and is monitoring the situation. Further details and status can be found at the Dropbox status page (https://status.dropbox.com/).
Posted May 28, 2024 - 12:02 EDT