Wi-Fi: "MIT SECURE"
Incident Report for MIT
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 15:41 EDT
Investigating
IS&T is currently investigating reports it has received regarding some users experiencing difficulties connecting to the "MIT SECURE" Wi-Fi network.
Posted Mar 26, 2024 - 14:21 EDT