Issues Sending Email via outgoing.mit.edu

Incident Report for MIT

Monitoring

IS&T has deployed a work-around, and we believe that outgoing.mit.edu is fully functional.
Posted Jun 23, 2026 - 17:58 EDT

Investigating

IS&T is investigating an issue affecting outgoing.mit.edu. Applications and services that rely on outgoing.mit.edu for outbound email delivery may be unable to send email at this time. We are actively working to restore service and will post updates as they become available.
Posted Jun 23, 2026 - 16:05 EDT
This incident affects: Email.