OC25 (Haystack): Network Connectivity to MITnet

Incident Report for MIT

Update

Connectivity to the building networks (Wi-Fi, VoIP, Internet) is restored, but full recovery of all Haystack circuits is still in progress.
Posted Mar 03, 2026 - 16:00 EST

Investigating

Connectivity between MITnet and Haystack (Buildings OC21, OC24, OC25, OC26) is currently down due to fiber/optical circuit issues. IS&T has engaged MIT-LL to further investigate optical network.
Posted Mar 03, 2026 - 06:44 EST
This incident affects: Network.